synaptic error

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

synaptic error

Eben King
I tried to install xmem, and as soon as I released the mouse to mark it
"install this", it told me:

,--
| xmem:
|
| Package xmem has no available version, but exists in the database.
| This typically means that the package was mentioned in a dependency and
| never uploaded, has been obsoleted or is not available with the contents
| of sources.list
'--

Do I need to install it from source, or is something fixable?

--
-eben    [hidden email]    ebmanda.redirectme.net:81
LIBRA:  A big promotion is just around the corner for someone
much more talented than you.  Laughter is the very best medicine,
remember that when your appendix bursts next week.  -- Weird Al
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

Bryan Lee
Try updating your package list and make sure your sources list is up to
date...

Thus Eben King hast written on Fri, Mar 13, 2015 at 12:27:19AM -0400, and, according to prophecy, it shall come to pass that:

> I tried to install xmem, and as soon as I released the mouse to mark
> it "install this", it told me:
>
> ,--
> | xmem:
> |
> | Package xmem has no available version, but exists in the database.
> | This typically means that the package was mentioned in a
> dependency and | never uploaded, has been obsoleted or is not
> available with the contents | of sources.list
> '--
>
> Do I need to install it from source, or is something fixable?
>
> --
> -eben    [hidden email]    ebmanda.redirectme.net:81
> LIBRA:  A big promotion is just around the corner for someone
> much more talented than you.  Laughter is the very best medicine,
> remember that when your appendix bursts next week.  -- Weird Al
> _______________________________________________
> slug mailing list
> [hidden email]
> https://www.suncoastlug.org/mailman/listinfo/slug
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

Eben King
On Fri, 13 Mar 2015, Bryan Lee wrote:

> Thus Eben King hast written on Fri, Mar 13, 2015 at 12:27:19AM -0400, and, according to prophecy, it shall come to pass that:

>> I tried to install xmem, and as soon as I released the mouse to mark
>> it "install this", it told me:
>>
>> ,--
>> | xmem:
>> |
>> | Package xmem has no available version, but exists in the database.
>> | This typically means that the package was mentioned in a
>> | dependency and never uploaded, has been obsoleted or is not
>> | available with the contents of sources.list
>> '--
>>
>> Do I need to install it from source, or is something fixable?

> Try updating your package list and make sure your sources list is up to
> date...

That sounds reasonable.  To what should I compare it?

--
-eben    [hidden email]    ebmanda.redirectme.net:81
LIBRA:  A big promotion is just around the corner for someone
much more talented than you.  Laughter is the very best medicine,
remember that when your appendix bursts next week.  -- Weird Al
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

PiousMinion
In reply to this post by Eben King
On Fri, Mar 13, 2015 at 12:27 AM, Eben King <[hidden email]> wrote:

> I tried to install xmem, and as soon as I released the mouse to mark it
> "install this", it told me:
>
> ,--
> | xmem:
> |
> | Package xmem has no available version, but exists in the database.
> | This typically means that the package was mentioned in a dependency and
> | never uploaded, has been obsoleted or is not available with the contents
> | of sources.list
> '--
>
> Do I need to install it from source, or is something fixable?


You didn't say which distro so I'm assuming ubuntu or a derivative for now.
According to this url, it was only available in 10.04 and 12.04.
http://packages.ubuntu.com/search?keywords=xmem&searchon=names&suite=all&section=all

You'll either have to build it from source or hope that one of these from
12.04 works.
AMD64:
http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/xmem_1.20-27.1_amd64.deb
x86:
http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/xmem_1.20-27.1_i386.deb



> --
> -eben    [hidden email]    ebmanda.redirectme.net:81
> LIBRA:  A big promotion is just around the corner for someone
> much more talented than you.  Laughter is the very best medicine,
> remember that when your appendix bursts next week.  -- Weird Al
> _______________________________________________
> slug mailing list
> [hidden email]
> https://www.suncoastlug.org/mailman/listinfo/slug
>
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

Eben King
On Fri, 13 Mar 2015, PiousMinion wrote:

> On Fri, Mar 13, 2015 at 12:27 AM, Eben King <[hidden email]> wrote:
>
>> I tried to install xmem, and as soon as I released the mouse to mark it
>> "install this", it told me:
>>
>> ,--
>> | xmem:
>> |
>> | Package xmem has no available version, but exists in the database.
>> | This typically means that the package was mentioned in a dependency and
>> | never uploaded, has been obsoleted or is not available with the contents
>> | of sources.list
>> '--
>>
>> Do I need to install it from source, or is something fixable?
>
> You didn't say which distro so I'm assuming ubuntu or a derivative for
> now.

Yeah sorry.  Ubuntu 14.04 LTS

> According to this url, it was only available in 10.04 and 12.04.
> http://packages.ubuntu.com/search?keywords=xmem&searchon=names&suite=all&section=all
>
> You'll either have to build it from source or hope that one of these from
> 12.04 works.
> AMD64:
> http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/xmem_1.20-27.1_amd64.deb
> x86:
> http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/xmem_1.20-27.1_i386.deb

Bummer, thanks.

Is it indicative of a problem that Synaptic offers it, but then un-offers
it?

--
-eben    [hidden email]    ebmanda.redirectme.net:81
LIBRA:  A big promotion is just around the corner for someone
much more talented than you.  Laughter is the very best medicine,
remember that when your appendix bursts next week.  -- Weird Al
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

PiousMinion
On Fri, Mar 13, 2015 at 9:42 AM, Eben King <[hidden email]> wrote:

> On Fri, 13 Mar 2015, PiousMinion wrote:
>
>  On Fri, Mar 13, 2015 at 12:27 AM, Eben King <[hidden email]> wrote:
>>
>>  I tried to install xmem, and as soon as I released the mouse to mark it
>>> "install this", it told me:
>>>
>>> ,--
>>> | xmem:
>>> |
>>> | Package xmem has no available version, but exists in the database.
>>> | This typically means that the package was mentioned in a dependency and
>>> | never uploaded, has been obsoleted or is not available with the
>>> contents
>>> | of sources.list
>>> '--
>>>
>>> Do I need to install it from source, or is something fixable?
>>>
>>
>> You didn't say which distro so I'm assuming ubuntu or a derivative for
>> now.
>>
>
> Yeah sorry.  Ubuntu 14.04 LTS
>
>  According to this url, it was only available in 10.04 and 12.04.
>> http://packages.ubuntu.com/search?keywords=xmem&searchon=
>> names&suite=all&section=all
>>
>> You'll either have to build it from source or hope that one of these from
>> 12.04 works.
>> AMD64:
>> http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/
>> xmem_1.20-27.1_amd64.deb
>> x86:
>> http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/
>> xmem_1.20-27.1_i386.deb
>>
>
> Bummer, thanks.
>
> Is it indicative of a problem that Synaptic offers it, but then un-offers
> it?
>
>
> It's not a serious problem, but not one you could fix anyway.
Well, not easily. :P  It simply means some package out there
depends(probably only suggests) xmem in it's description file.  It's really
no big deal. :)

--
> -eben    [hidden email]    ebmanda.redirectme.net:81
> LIBRA:  A big promotion is just around the corner for someone
> much more talented than you.  Laughter is the very best medicine,
> remember that when your appendix bursts next week.  -- Weird Al
> _______________________________________________
> slug mailing list
> [hidden email]
> https://www.suncoastlug.org/mailman/listinfo/slug
>
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

Eben King
In reply to this post by PiousMinion
On Fri, 13 Mar 2015, PiousMinion wrote:

> On Fri, Mar 13, 2015 at 12:27 AM, Eben King <[hidden email]> wrote:
>
>> I tried to install xmem, and as soon as I released the mouse to mark it
>> "install this", it told me:

[synaptic: "Just kidding!"]

>> Do I need to install it from source, or is something fixable?
>
> You didn't say which distro so I'm assuming ubuntu or a derivative for now.
> According to this url, it was only available in 10.04 and 12.04.
> http://packages.ubuntu.com/search?keywords=xmem&searchon=names&suite=all&section=all
>
> You'll either have to build it from source or hope that one of these from
> 12.04 works.
> AMD64:
> http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/xmem_1.20-27.1_amd64.deb
> x86:
> http://mirrors.kernel.org/ubuntu/pool/universe/x/xmem/xmem_1.20-27.1_i386.deb

I tried compiling it but ran into a problem beyond my C/C++ abilities.  I
think it was something like it needs a header, Google the error, find the
missing package, install it, same problem.

So, can anyone recommend a program which does roughly the same thing as
xmem?  Searching installable programs for "memory" or "RAM" is useless.  I
tried gmemusage which has a vaguely similar display only xmem shows you
actual RAM and swap differently, whereas to gmemusage they're all the same.

For those not familiar with xmem, it has a display of all memory, and uses
different colors for app, cache, buffers, swap, maybe a few more.

--
-eben    [hidden email]    ebmanda.redirectme.net:81
LIBRA:  A big promotion is just around the corner for someone
much more talented than you.  Laughter is the very best medicine,
remember that when your appendix bursts next week.  -- Weird Al
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug
Reply | Threaded
Open this post in threaded view
|

Re: synaptic error

Eben King
On Sat, 14 Mar 2015, Eben King wrote:

> So, can anyone recommend a program which does roughly the same thing as xmem?
> Searching installable programs for "memory" or "RAM" is useless.  I tried
> gmemusage which has a vaguely similar display only xmem shows you actual RAM
> and swap differently, whereas to gmemusage they're all the same.
>
> For those not familiar with xmem, it has a display of all memory, and uses
> different colors for app, cache, buffers, swap, maybe a few more.

I found xmm http://www.linuxinsight.com/xmm_utility.html .  Given its age,
general appearance, code size, etc. I'm thinking it's a proto-xmem.  The
appearance is very much like xmem but configuration is a bitch.  I'm hoping
there's a config file somewhere because running

xmm -bg '#FFD' -fg black -hl grey50 -usedcolor '#a42a2c' -activecolor
'#fc0204' -inactivecolor '#fcfe04' -freecolor '#04fe04' -swapcolor '#fca604'

every time is for the birds.  But hey, you can't argue with a 25k
executable, and that's before stripping!

--
-eben    [hidden email]    ebmanda.redirectme.net:81
LIBRA:  A big promotion is just around the corner for someone
much more talented than you.  Laughter is the very best medicine,
remember that when your appendix bursts next week.  -- Weird Al
_______________________________________________
slug mailing list
[hidden email]
https://www.suncoastlug.org/mailman/listinfo/slug